Cloned Micropod 2 Review: DRBIII on PT Cruiser & Dodge, wiTECH on Dodge

I’m happy to report that my clone wietch Micropod 2 off obdii365.com does work, this unit doesn’t use a HDD, just install witech natively, it comes with witech 17.04 and drb 3 as well. This is what I have.

 

Look here

micropod-2-witech-drb-3-review-1

It’s a small package, coming with a VCI pod, a usb cable and a CD inside software

micropod-2-witech-drb-3-review-2

Pins inside the VCI pod connector are built well and I’ve never had connection issues

micropod-2-witech-drb-3-review-3

Sticker lol…. put it on and it’s definitely same as the original

micropod-2-witech-drb-3-review-4

And also on the CD it has wiTECH software version 17.04.27 – it’s the newest version tested by their professionals.

and also it has the DRB stub, DRB emulator, Enhanced DRB Stub and three versions of the Enhanced emulator.

 

The wiTECH installation is easy with the help of a Youtube video they’ve uploaded.

And DRBIII emulator with Micropod 2 is an old topic on the web. This is the tutorial i’m using. http://blog.obdii365.com/2018/06/16/install-drbiii-emulator-for-micropod-2-on-windows-7/

This guy has the same Micropod as me. It did work!

 

So far, I have the Micropod 2 on three cars.

 

DRBIII emulator + 2003 PT Cruiser: works  (the main things lol)

DRBIII emulator + 2004 Dodge: works

wiTECH + 2010 Charger: works

 

Btw, Micropod 2 with DRBIII emulator work for old Chysler the year 1997 – 2004 (2005)

And with wiTECH only works for Chrysler made after the year 2003

 

First, I tested on a 2003 PT Cruiser.

 

Basically no other modules other than the Engine, work. I cannot connect to the transmission, ABS, VTSS, SKIM, radio, cluster, etc. But everything in the engine module can be tested, actuated, etc.
Luckily for me, I really only needed the DRBIII to write the Pinion factor for manual transmissions, which is conveniently in the ‘engine’ part which works.
Maybe I really need to invest in an older VCI pod so that everything else works.

 

Then, I also tested it on a 2010 Charger under witech and works flawlessly, and got a 2004 Dodge pickup and under the emulator worked perfectly.

 

 

Edit to update:

I already called my locksmith, who drives an 04 Sprinter to try it as well.

 

 

 

So I had a chance to test my Micropod II with not only wiTECH but also the DRBIII enhanced emulator. Both work good!

 

 

Say thanks if it helps 😀

 

sales