How to Fix Autel IM608 Pro Error “Incorrect Component Installed”?

Problem: Used Autel im608 Pro to add key on a 2013 Mazda CX-5, it failed and now has the key light fault will not clear.

01 Autel Im608 Pro 2013 Mazda Cx 5 Key Add

And this is the fault code: Incorrect Component Installed… I used a genuine key.

02 Autel Im608 Pro 2013 Mazda Cx 5 Key Add

 

This is the original and the one I tried to program.

03 Autel Im608 Pro 2013 Mazda Cx 5 Key Add

04 Autel Im608 Pro 2013 Mazda Cx 5 Key Add

I have this old key in the van.

05 Autel Im608 Pro 2013 Mazda Cx 5 Key Add

 

How to fix Autel im608 Pro “Incorrect Component Installed”?

Both keys (previous and new) need to be the same type. If one is 3-button and the other 2-button. You mentioned you used a genuine key, could be possible that the other key is aftermarket? 2 identical genuine keys will work ok. 2 identical aftermarket keys will also work ok. But don’t mix-match them.

 

Ske13e is 433mhz you would use for NZ new models. Ske13d is 315mhz and the correct one for Jap import. yes you can reuse a previously programmed one.

if you delete all keys then do all keys lost with 2 matching. Both remotes are 2 button type.

 

Update:

Just fixed it the was both 2 button but part numbers on the key was different … the car I was doing was a import and I used NZ frequency key luckily had a old fob to do again.

 

Thanks to @ Josh Faloon for his feedback.

 

Any question on Autel im608 Pro, contact at https://www.obdii365.com/ .

sales